MySQL Workbench如何导出特定版本的SQL文件

最近在用MySQL Workbench建模的过程中突然发现导出的SQL建库文件无法运行,报各种错。

仔细看了一下SQL文件中的新建索引部分多了一些关键字“VISIBLE”。

查了一下,这是MySQL8.0的特性,而我的服务器是Mysql5.5很显然是无法支持的,问题是找到了,如何解决呢?

找了一圈,在配置中找到的,具体设置方式如下:

当你指定mysql版本后,导出的建库语句也是兼容指定版本的SQL。